Note - Before this Scenario you should read Question 30 To Question 35 in previous Chapter RIP - INTERVIEW QUESTIONS
How To Manipulating RIP Metrics Using Offset-Lists
In this scenario these three router configured with RIPv2 and configuration of each router given below
R 1 Configuration
!version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/1/1
ip address 192.168.30.1 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.10.0
network 192.168.20.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
password console
logging synchronous
login
!
line aux 0
password aux
login
!
line vty 0 4
password telnet
login
line vty 5 15
password telnet
login
!
!
!
end
R 2 Configuration
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.20.2 255.255.255.0
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.168.10.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
ip address 192.168.30.1 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 172.16.0.0
network 192.168.10.0
network 192.168.30.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
password console
logging synchronous
login
!
line aux 0
password aux
login
!
line vty 0 4
password telnet
login
line vty 5 15
password telnet
login
!
!
!
end
R 3 Configuration
!version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.2.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.20.2 255.255.255.0
clock rate 2000000
!
interface Serial0/1/1
ip address 192.168.30.2 255.255.255.0
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 10.0.0.0
network 192.168.20.0
network 192.168.30.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
exec-timeout 0 0
password aux
login
!
line vty 0 4
password telnet
login
line vty 5 15
password telnet
login
!
!
!
end
Task
- R1 reaches 10.2.2.0 network via 192.168.20.2, but the requirement is R1 should reach 10.2.2.0 network via R2 .
- R3 reaches 10.1.1.0 network via 192.168.20.0, but the requirement is R3 should reach 10.1.1.0 network via R2
Now Let's check
R1#Show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, FastEthernet0/1
R 10.2.2.0 [120/1] via 192.168.20.2, 00:00:27, Serial0/1/1
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.10.0 [120/1] via 192.168.10.2, 00:00:23, Serial0/1/0
C 192.168.10.0/24 is directly connected, Serial0/1/0
C 192.168.20.0/24 is directly connected, Serial0/1/1
R 192.168.30.0/24 [120/1] via 192.168.10.2, 00:00:23, Serial0/1/0
[120/1] via 192.168.20.2, 00:00:27, Serial0/1/1
If you will notice in the above output the you will find R1 reaches 10.2.2.0 network via 192.168.20.2 due to lowest hop count but the requirement is R1 should reach 10.2.2.0 network via R2 .
Check through "Debug IP RIP" command
R1#Debug ip rip
RIP protocol debugging is on
R1#RIP: received v2 update from 192.168.10.2 on Serial0/1/0
10.2.2.0/24 via 0.0.0.0 in 2 hops .................................. HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.30.0/24 via 0.0.0.0 in 1 hops
R1#RIP: received v2 update from 192.168.20.2 on Serial0/1/1
10.2.2.0/24 via 0.0.0.0 in 1 hops ...................................... LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.30.0/24 via 0.0.0.0 in 1 hops
R1#RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (10.1.1.1)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 2, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.10.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 1, tag 0
10.2.2.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.20.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 1, tag 0
You can see here route from R1 to 10.2.2.0 network via 192.168.20.2 has only one hop count but route from R1 to 10.2.2.0 network via R2 has two hop count.
Now Check R3
R3#Show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
R 10.1.1.0 [120/1] via 192.168.20.1, 00:00:13, Serial0/1/0
C 10.2.2.0 is directly connected, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.10.0 [120/1] via 192.168.30.1, 00:00:01, Serial0/1/1
R 192.168.10.0/24 [120/1] via 192.168.30.1, 00:00:01, Serial0/1/1
[120/1] via 192.168.20.1, 00:00:13, Serial0/1/0
C 192.168.20.0/24 is directly connected, Serial0/1/0
C 192.168.30.0/24 is directly connected, Serial0/1/1
If you will notice in the above output the you will find R3 reaches 10.1.1.0 network via 192.168.20.1 due to lowest hop count but the requirement is R3 should reach 10.1.1.0 network via R2
Check through "Debug IP RIP" command
R3#Debug ip rip
RIP protocol debugging is on
R3#RIP: received v2 update from 192.168.30.1 on Serial0/1/1
10.1.1.0/24 via 0.0.0.0 in 2 hops ...................................... HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: received v2 update from 192.168.20.1 on Serial0/1/0
10.1.1.0/24 via 0.0.0.0 in 1 hops ........................................ LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (10.2.2.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.30.2)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.20.2)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
RIP protocol debugging is on
R3#RIP: received v2 update from 192.168.30.1 on Serial0/1/1
10.1.1.0/24 via 0.0.0.0 in 2 hops ...................................... HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: received v2 update from 192.168.20.1 on Serial0/1/0
10.1.1.0/24 via 0.0.0.0 in 1 hops ........................................ LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (10.2.2.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.30.2)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.20.2)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
You can see here route from R3 to 10.1.1.0 network via 192.168.20.0 has ony one hop count but route from R3 to 10.1.1.0 network via R2 has two hop count.
Now our requirement is R1 should reach 10.2.2.0 network via R2 . So you will have to configure offset-list in R 1 for 192.168.20.0
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#access-list 10 permit 10.0.0.0 255.255.255.0
R1(config)#router rip
R1(config-router)#network 192.168.20.0
R1(config-router)#offset-lists 10 in 2 s0/1/1
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#access-list 10 permit 10.0.0.0 255.255.255.0
R1(config)#router rip
R1(config-router)#network 192.168.20.0
R1(config-router)#offset-lists 10 in 2 s0/1/1
Now our requirement is R3 should reach 10.1.1.0 network via R2. o you will have to configure offset-list in R 3 for 192.168.20.0
R3#config t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#access-list 20 permit 10.0.0.0 255.255.255.0
R3(config)#router rip
R3(config-router)#network 192.168.20.0
R3(config-router)#offset-lists 20 in 2 s0/1/0
Now Let's check R1 router
Now you can see in the above output path has been changed
You can see here route from R1 to 10.2.2.0 network via 192.168.20.2 has three hop count but route from R1 to 10.2.2.0 network via R2 has two hop count. Because you have configured Offset List.
Now Let's check R3 router
R3#config t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#access-list 20 permit 10.0.0.0 255.255.255.0
R3(config)#router rip
R3(config-router)#network 192.168.20.0
R3(config-router)#offset-lists 20 in 2 s0/1/0
Now Let's check R1 router
R1#Show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, FastEthernet0/1
R 10.2.2.0 [120/2] via 192.168.10.2, 00:00:27, Serial0/1/1
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.10.0 [120/1] via 192.168.10.2, 00:00:23, Serial0/1/0
C 192.168.10.0/24 is directly connected, Serial0/1/0
C 192.168.20.0/24 is directly connected, Serial0/1/1
R 192.168.30.0/24 [120/1] via 192.168.10.2, 00:00:23, Serial0/1/0
[120/1] via 192.168.20.2, 00:00:27, Serial0/1/1
Now you can see in the above output path has been changed
Check through "Debug IP RIP" command
R1#Debug ip rip
RIP protocol debugging is on
R1#RIP: received v2 update from 192.168.10.2 on Serial0/1/0
10.2.2.0/24 via 0.0.0.0 in 2 hops .................................. LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.30.0/24 via 0.0.0.0 in 1 hops
R1#RIP: received v2 update from 192.168.20.2 on Serial0/1/1
10.2.2.0/24 via 0.0.0.0 in 3 hops ...................................... HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.30.0/24 via 0.0.0.0 in 1 hops
R1#RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (10.1.1.1)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 2, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.10.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 1, tag 0
10.2.2.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.20.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 1, tag 0
You can see here route from R1 to 10.2.2.0 network via 192.168.20.2 has three hop count but route from R1 to 10.2.2.0 network via R2 has two hop count. Because you have configured Offset List.
Now Let's check R3 router
R3#Show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
R 10.1.1.0 [120/3] via 192.168.30.1, 00:00:13, Serial0/1/0
C 10.2.2.0 is directly connected, FastEthernet0/0
172.16.0.0/24 is subnetted, 1 subnets
R 172.16.10.0 [120/1] via 192.168.30.1, 00:00:01, Serial0/1/1
R 192.168.10.0/24 [120/1] via 192.168.30.1, 00:00:01, Serial0/1/1
[120/1] via 192.168.20.1, 00:00:13, Serial0/1/0
C 192.168.20.0/24 is directly connected, Serial0/1/0
C 192.168.30.0/24 is directly connected, Serial0/1/1
Now you can see in the above output path has been changed
Check through "Debug IP RIP" command
R3#Debug ip rip
RIP protocol debugging is on
R3#RIP: received v2 update from 192.168.30.1 on Serial0/1/1
10.1.1.0/24 via 0.0.0.0 in 2 hops ...................................... LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: received v2 update from 192.168.20.1 on Serial0/1/0
10.1.1.0/24 via 0.0.0.0 in 3 hops ........................................ HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (10.2.2.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.30.2)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.20.2)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
You can see here route from R3 to 10.1.1.0 network via 192.168.20.0 has three hop count but route from R3 to 10.1.1.0 network via R2 has two hop count. Because we have configured Offset Lists
Now our tasks have completed.
RIP protocol debugging is on
R3#RIP: received v2 update from 192.168.30.1 on Serial0/1/1
10.1.1.0/24 via 0.0.0.0 in 2 hops ...................................... LOWEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 1 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: received v2 update from 192.168.20.1 on Serial0/1/0
10.1.1.0/24 via 0.0.0.0 in 3 hops ........................................ HIGHEST HOP COUNT
172.16.10.0/24 via 0.0.0.0 in 2 hops
192.168.10.0/24 via 0.0.0.0 in 1 hops
RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (10.2.2.1)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/1 (192.168.30.2)
RIP: build update entries
10.1.1.0/24 via 0.0.0.0, metric 2, tag 0
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
192.168.20.0/24 via 0.0.0.0, metric 1, tag 0
RIP: sending v2 update to 224.0.0.9 via Serial0/1/0 (192.168.20.2)
RIP: build update entries
10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
172.16.10.0/24 via 0.0.0.0, metric 2, tag 0
192.168.30.0/24 via 0.0.0.0, metric 1, tag 0
You can see here route from R3 to 10.1.1.0 network via 192.168.20.0 has three hop count but route from R3 to 10.1.1.0 network via R2 has two hop count. Because we have configured Offset Lists
Now our tasks have completed.
0 comments:
Post a Comment
If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.