BGP - [Part 11] - EBGP BASIC CONFIGURATION

Question - 1 How can we configure EBGP between two router ?

We can configure EBGP in multiple way, so before starting the BGP configuration you should know the below basic IBGP concept, it will be helpful.

1. Simple EBGP between two router  -
  • Router1 Configuration - 

Router1#show running-config
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.2 remote-as 500
 no auto-summary
  • Router2 Configuration - 

Router2#show running-config
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.1 remote-as 400
 no auto-summary

Output - 



2. EBGP with Loop-back network advertisement - 
For the loop-back reachability, you will have to advertise loop-back network under the BGP 
  • Router1 Configuration - 
Router1#show running-config
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 speed 100
 full-duplex
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 network 11.11.11.0 mask 255.255.255.0
 neighbor 192.167.23.2 remote-as 500
 no auto-summary
  • Router2 Configuration - 
Router2#show running-config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 speed 100
 full-duplex
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.0 mask 255.255.255.0
 network 22.22.22.0 mask 255.255.255.0
 neighbor 192.167.23.1 remote-as 400
 no auto-summary

Output - 



3. EBGP with Static Route (Method 1) - 
You can also use the static route or other IGP routing protocol for loop-back network reachability, instead of loop-back network advertisement.
  • Router1 Configuration - 
Router1#show running-config
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 speed 100
 full-duplex
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.2 remote-as 500
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip route 2.2.2.0 255.255.255.0 192.167.23.2
ip route 22.22.22.0 255.255.255.0 192.167.23.2
  • Router2 Configuration - 
Router2#show running-config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 speed 100
 full-duplex
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.1 remote-as 400
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip route 1.1.1.0 255.255.255.0 192.167.23.1
ip route 11.11.11.0 255.255.255.0 192.167.23.1


Output - 



4. EBGP with Static IP (Method 2) - 
You can also establish the neighbor-ship via loop-back network, but you will have to use static route or other IGP routing protocol for loop-back network reach-ability.
  • Router1 Configuration - 
Router1#show running-config
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 speed 100
 full-duplex
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 500
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip route 2.2.2.0 255.255.255.0 192.167.23.2
ip route 22.22.22.0 255.255.255.0 192.167.23.2
  • Router2 Configuration - 
Router2#show running-config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 speed 100
 full-duplex
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 400
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
 no auto-summary

!
no ip http server
no ip http secure-server
!
ip route 1.1.1.0 255.255.255.0 192.167.23.1
ip route 11.11.11.0 255.255.255.0 192.167.23.1

Output - 



5. EBGP with OSPF (Method-1) - 
Here we are using OSPF for loop-back network reachability. 
  • Router1 Configuration - 
Router1#show running-config
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 speed 100
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 11.11.11.0 0.0.0.255 area 0
 network 192.167.23.0 0.0.0.255 area 0
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.2 remote-as 500
 no auto-summary
  • Router2 Configuration - 
Router2#show running-config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 speed 100
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.0 0.0.0.255 area 0
 network 22.22.22.0 0.0.0.255 area 0
 network 192.167.23.0 0.0.0.255 area 0
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.167.23.1 remote-as 400
 no auto-summary

Output - 

6. EBGP with OSPF (Method-2) - 

  • Router1 Configuration - 
Router1#show running-config
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.1 255.255.255.0
 speed 100
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 11.11.11.0 0.0.0.255 area 0
 network 192.167.23.0 0.0.0.255 area 0
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 500
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 22.22.22.22 remote-as 500
 neighbor 22.22.22.22 ebgp-multihop 2
 neighbor 22.22.22.22 update-source Loopback1
 no auto-summary

  • Router2 Configuration - 
Router2#show running-config
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.167.23.2 255.255.255.0
 speed 100
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.0 0.0.0.255 area 0
 network 22.22.22.0 0.0.0.255 area 0
 network 192.167.23.0 0.0.0.255 area 0
!
router bgp 500
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 400
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 11.11.11.11 remote-as 400
 neighbor 11.11.11.11 ebgp-multihop 2
 neighbor 11.11.11.11 update-source Loopback1
 no auto-summary


Output - 

SHARE

Anubhav Upadhyay

Hello and welcome to networktopic Blog. My name is Anubhav. I am a Senior Network Egineer. I have created this blog specially to serve interview questions and answer on Network Routing and Switching, I will try my best to serve correct and updated networking knowledge for you as per my corporate experience.

  • Image
  • Image
  • Image
  • Image
  • Image
    Blogger Comment
    Facebook Comment

0 comments:

Post a Comment

If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.