- Before BGP Next Hop Self, we should know the "what is the next hop exactly ?". Next hop is IP to reach the next Autonomous System. For Example check the below topology, if Router R4 will advertise any route to R3, then 192.167.24.1 will be next hop for Router R4.
- IBGP has an issue. When an update send within the same AS, then next hop will be same, sometimes it can cause reach-ability issue, we can change this behavior by using "Next-Hop-Self" command.
- Note that when an update send between different Autonomous System then next hop will be change.
Please check the below example, I will show you both situation.
- When an update send within the same AS - Next hop will be same (We can change this behavior by using "Next-Hop-Self" command).
- When an update send between different AS - Next hop will be change.
So you can see the above topology, there are four routers
- R1 and R2 in AS100
- R3 in AS200
- R4 in AS300
- We will advertise the network for point to point reach-ability of devices
- We will use "Next Hop Self" command to change next hop in IBGP
Without Next Hop Self
Now below are the configuration - R1 Configuration -
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.167.22.2 remote-as 100
no auto-summary
R2 Configuration -
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.167.22.1 remote-as 100
neighbor 192.167.23.2 remote-as 200
no auto-summary
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.167.22.1 remote-as 100
neighbor 192.167.23.2 remote-as 200
no auto-summary
R3 Configuration -
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.167.24.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.1 remote-as 100
neighbor 192.167.24.2 remote-as 300
no auto-summary
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.167.24.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.1 remote-as 100
neighbor 192.167.24.2 remote-as 300
no auto-summary
R4 Configuration -
interface Loopback1ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet2/0
ip address 192.167.24.2 255.255.255.0
duplex auto
speed auto
!
router bgp 300
no synchronization
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0
neighbor 192.167.24.1 remote-as 200
no auto-summary
Verification -
R2 has installed 1.1.1.0 /24 in its BGP table and it is a valid route, the next hop is 192.167.23.2 .
Also R3 has installed 1.1.1.0 /24 in its BGP table and it is a valid route, the next hop is 192.167.24.2 .
So as per above output , we found below things -
- There is no point to point reach-ability, we cannot ping 1.1.1.1 from R1 and R2 Router.
- As per IBGP issue, in R1 and R2 same next hop is showing for network 1.1.1.0/24. R1 did not change the next hop.
- But you can notice there is no any issue with EBGP next hop, R2 has next hop 192.167.23.2 for 1.1.1.0/24 and R3 has next hop 192.167.24.2 for 1.1.1.0/24. So issue only with IBGP .
So now we will advertise the network and will use "next-hop-self" command to improve above things in next part.
Click here for next part
0 comments:
Post a Comment
If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.