With Next Hop Self
Below is the new Configuration -
R1 Configuration -
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 192.167.22.0
neighbor 192.167.22.2 remote-as 100
no auto-summary
R2 Configuration -
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 192.167.23.0
neighbor 192.167.22.1 remote-as 100
neighbor 192.167.22.1 next-hop-self
neighbor 192.167.23.2 remote-as 200
no auto-summary
R3 Configuration -
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.167.24.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 192.167.24.0
neighbor 192.167.23.1 remote-as 100
neighbor 192.167.24.2 remote-as 300
no auto-summary
R4 Configuration -
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet2/0
ip address 192.167.24.2 255.255.255.0
duplex auto
speed auto
!
router bgp 300
no synchronization
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0
neighbor 192.167.24.1 remote-as 200
no auto-summary
Now in R1, R2 and R3 we have advertised the network and configured the next-hop-self
Verification -
Now we will verify -
Now R1 learns the prefix and installed it in the routing table and R1 has next hop 192.167.22.2 for network 1.1.1.0/24, it means next hop has been changed due to "next-hop-self" command
Now we have point to point reach-ability, we can ping network 1.1.1.0/24 from R1, R2 and R3 router.
0 comments:
Post a Comment
If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.