Without "update-source loopback" Command
Configuration -
R1 Configuration -
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ebgp-multihop 2
no auto-summary
!
ip route 2.2.2.0 255.255.255.0 192.167.22.2
ip route 2.2.2.0 255.255.255.0 192.167.23.2
R2 Configuration -
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
no auto-summary
!
ip route 1.1.1.0 255.255.255.0 192.167.23.1
ip route 1.1.1.0 255.255.255.0 192.167.22.1
Verification -
R1#show
ip bgp summary
BGP router identifier 1.1.1.1,
local AS number 100
BGP table version is 1, main
routing table version 1
1 network entries using 117 bytes
of memory
1 path entries using 52 bytes of
memory
2/0 BGP path/bestpath attribute
entries using 248 bytes of memory
0 BGP route-map cache entries
using 0 bytes of memory
0 BGP filter-list cache entries
using 0 bytes of memory
BGP using 417 total bytes of
memory
BGP activity 1/0 prefixes, 1/0
paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 200
0 0 0
0 0 never Active
R2#show
ip bgp summary
BGP router identifier 2.2.2.2,
local AS number 200
BGP table version is 1, main
routing table version 1
1 network entries using 117 bytes
of memory
1 path entries using 52 bytes of
memory
2/0 BGP path/bestpath attribute
entries using 248 bytes of memory
0 BGP route-map cache entries
using 0 bytes of memory
0 BGP filter-list cache entries
using 0 bytes of memory
BGP using 417 total bytes of
memory
BGP activity 1/0 prefixes, 1/0
paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100
2 2 0
0 0 Active 0
With "update-source loopback" Command
Configuration -
R1 Configuration -
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback1
no auto-summary
!
ip route 2.2.2.0 255.255.255.0 192.167.22.2
ip route 2.2.2.0 255.255.255.0 192.167.23.2
R2 Configuration -
interface Loopback1
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
no auto-summary
!
ip route 1.1.1.0 255.255.255.0 192.167.23.1
ip route 1.1.1.0 255.255.255.0 192.167.22.1
Verification -
R1#show
ip bgp summary
BGP router identifier 1.1.1.1,
local AS number 100
BGP table version is 4, main
routing table version 4
2 network entries using 234 bytes
of memory
2 path entries using 104 bytes of
memory
3/2 BGP path/bestpath attribute
entries using 372 bytes of memory
1 BGP AS-PATH entries using 24
bytes of memory
0 BGP route-map cache entries
using 0 bytes of memory
0 BGP filter-list cache entries
using 0 bytes of memory
BGP using 734 total bytes of
memory
BGP activity 2/0 prefixes, 2/0
paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 200
6 6 4
0 0 00:02:38 1
R2#show
ip bgp summary
BGP router identifier 2.2.2.2,
local AS number 200
BGP table version is 4, main
routing table version 4
2 network entries using 234 bytes
of memory
2 path entries using 104 bytes of
memory
3/2 BGP path/bestpath attribute
entries using 372 bytes of memory
1 BGP AS-PATH entries using 24
bytes of memory
0 BGP route-map cache entries
using 0 bytes of memory
0 BGP filter-list cache entries
using 0 bytes of memory
BGP using 734 total bytes of
memory
BGP activity 2/0 prefixes, 2/0
paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100
6 6 4
0 0 00:02:46 1
0 comments:
Post a Comment
If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.