- In EBGP, by default only two directly connected Cisco IOS router can establish a neighbor adjacency.
- So as per BGP requirement, the external peers should be directly connected. "Neighbor EBGP-multihop" command breaks this barrier, it will allow the neighbor ship adjacency between indirectly connected EBGP peer.
- EBGP router has TTL value 1 by default, if BGP neighbor is more than one hop away, then TTL value will be decrease to 0 and it will be discarded.
- TTL range is from 1 to 255. We can set it manually via "neighbor ebgp-multihop" command.
- R1 and R3 are in different AS, and non BGP router R2 is available between them, so R1 and R3 are not directly connected.
- If R1 wants to establish the neighbor ship with R3 then TTL value should be 2, because R3 is 2 hop away from R1.
- When R1 will reach to R2 then TTL value will be decrease by 1 and it will be 1.
- When R1 will reach to R3 then TTL value will be decrease by 2 and it will be 0.
- After that neighbor ship will be establish between indirectly connected EBGP peer R1 and R3.
Without "neighbor ebgp-multihop" command
Configuration -
R1 Configuration -
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.3 remote-as 200
no auto-summary
!
ip route 192.167.23.0 255.255.255.0 192.167.22.2
R2 Configuration -
interface FastEthernet0/0
ip address 192.167.22.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
R3 Configuration -
interface FastEthernet1/0
ip address 192.167.23.3 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.22.1 remote-as 100
no auto-summary
!
ip route 192.167.22.0 255.255.255.0 192.167.23.2
Verification -
R1#show ip bgp summary
BGP router identifier 192.167.22.1, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.167.23.3 4 200 0 0 0 0 0 never Active
R3#show ip bgp summary
BGP router identifier 192.167.23.3, local AS number 200
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.167.22.1 4 100 0 0 0 0 0 never Active
You can see in above output, configuration is correct but there is no neighbor-ship adjacency, because both EBGP peer R1 and R3 are indirectly connected.
With "neighbor ebgp-multihop" command
Configuration -
Now we configured "neighbor ebgp-multihop" command on both Router R1 and R3
R1 Configuration -
interface FastEthernet0/0
ip address 192.167.22.1 255.255.255.0
duplex auto
speed auto
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.3 remote-as 200
neighbor 192.167.23.3 ebgp-multihop 2
no auto-summary
!
ip route 192.167.23.0 255.255.255.0 192.167.22.2
R3 Configuration -
interface FastEthernet1/0
ip address 192.167.23.3 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.22.1 remote-as 100
neighbor 192.167.22.1 ebgp-multihop 2
no auto-summary
!
ip route 192.167.22.0 255.255.255.0 192.167.23.2
Verification -
Now check the below output
R1#show ip bgp summary
BGP router identifier 192.167.22.1, local AS number 100
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.167.23.3 4 200 15 15 1 0 0 00:11:42 0
R3#show ip bgp summary
BGP router identifier 192.167.23.3, local AS number 200
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.167.22.1 4 100 15 15 1 0 0 00:11:49 0
Now we can see in above output, now after using "neighbor ebgp-multihop" command neighor-ship established between both indirectly connected EBGP peer R1 and R2.
0 comments:
Post a Comment
If you like my posts then please comment and if you don’t like then please suggest me to improve, and if you have any query related to post then please text me through the comment box or mail me on upadhyayambition@gmail.com , I will try my best to solve your queries as soon as possible.