There are 3 IBGP routers. As per Split Horizon rule Router R1 can send a route to R2, and R2 will receive the route from R1 but it will not send to R3. We can break the rule via Route Reflector.
Please check the below configuration.
interface Loopback1
ip address 10.10.10.10 255.255.255.0
!
interface FastEthernet1/0
ip address 192.167.23.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
neighbor 192.167.23.2 remote-as 200
no auto-summary
R2 Configuration -
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.167.24.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.1 remote-as 200
neighbor 192.167.24.2 remote-as 200
no auto-summary
R3 Configuration -
interface FastEthernet2/0
ip address 192.167.24.2 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.24.1 remote-as 200
no auto-summary
R2#show ip bgp 10.10.10.10
BGP routing table entry for 10.10.10.0/24, version 6
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
Local
192.167.23.1 from 192.167.23.1 (192.167.23.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
now verify it, you can see in above output, Router R2 was received a route from 192.167.23.1 (R1).
now check, it will be advertise this route to R3 or not ?
R2#show ip bgp neighbors 192.167.24.2 advertised-routes
Total number of prefixes 0
now you can see in above output, R2 is not advertising this route to R3, we can do this via route reflector.
we will configure Route Reflector Client on Router R2 -
Configuration -
R2 Configuration -
interface FastEthernet1/0
ip address 192.167.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.167.24.1 255.255.255.0
duplex auto
speed auto
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.167.23.1 remote-as 200
neighbor 192.167.23.1 route-reflector-client
neighbor 192.167.24.2 remote-as 200
neighbor 192.167.24.2 route-reflector-client
no auto-summary
Verification -
Now check again, R2 will be advertise to R3 or not ?
R2#show ip bgp neighbors 192.167.24.2 advertised-routes
BGP table version is 8, local router ID is 192.167.24.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i10.10.10.0/24 192.167.23.1 0 100 0 i
Total number of prefixes 1
- It is set by RR, we can see, this is the IP address of R1.
- If any IBGP router will receive an update with its own originator ID, then it will be discarded.
- It is the router ID of the RR.
- In a large topology, may be multiple RR will be available, so between the route reflectors we still have to configure full mesh IBGP. It is possible that a loops between these route reflectors, so when a route reflector find its own cluster ID in update, then update will be discarded.
Thnku sooooooo much for this content these configuration help me much in my work I'll do it easily thnx alot.
ReplyDelete